Upgrading from 1.5.x to 2.x

Upgrading major releases is always tricky. Major release change is signalized by the first, the most important digit in version number change, in this case 1.x.y -> 2.0.0. Major release brings major changes. The trickiest changes are always database related. The good part, is that although there are lots of changes between Papermerge 1.x.y and 2.0.0, for database level – there are not so many.

Before performing upgrades, please backup your data. You need to backup two things:

  • database
  • media directory (where documents are stored)

If you run 1.5.x version and want to upgrade to 2.0.x you need to first and most importantly upgrade to the latest stable 1.5.5 release. Once you have 1.5.5 up and running and you backed up all you data – you are ready to upgrade.

Please upgrade from 1.5.5 directly to 2.0.0rc38, i.e. skip 2.0.0rc35 release as it is “broken”.